Se descubre vulnerabilidad crítica en el kernel de Linux

linux-logo-new-tux-crystalized150Ayer un usuario de SUSE descubrió una vulnerabilidad grabe en el núcleo de Linux que permite a usuarios sin privilegios (no-root) obtenener privilegios de super-usuario y que es capaz de corromper la memoria asignada al núcleo.

Las versiones del kernel afectada va desde la 2.6.31 hasta la actual que es la 3.14.3

Según leemos en la web /etc/cron.d:

  • El fallo consiste en que si se da simultáneamente más de una orden de escritura a la misma pseudoterminal (una TTY), se puede producir lo que se conoce como un “desbordamiento de búfer” (buffer overflow); es decir, un intento de escribir más allá de la memoria asignada a una variable del procedimiento que se está ejecutando en ese momento. Como el procedimiento que lleva a cabo una orden de escritura en una pseudoterminal, llamado n_tty_write(), es una función del núcleo Linux, al producirse el desbordamiento, habremos sobreescrito memoria del mismísimo núcleo hasta donde queramos.

Este fallo es para tomárselo en serio ya que puede afectar a infinidad de servidores y dispositivos Android.  Se ha creado un exploit que podéis ver aquí, para probar el fallo en sistemas con arquitecturas de 64 bits.

La mayoría de las distribuciones ya han sacado parquetes para solucionar el fallo, los podéis ver en la siguiente lista:

Así que ya sabemos todos, actualizar nuestros sistemas lo antes posible.

Vía: lamiradadelreplicannte.com y /etc/cron.d

You may also like...

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR